読者です 読者をやめる 読者になる 読者になる

Rubellum fly light

PHP日記

WordpressでFTP接続情報を求められたときのメモ

さくらのVPS

さくらのVPSにWordpressをインストールしたのだけれど、プラグインの更新やテーマのインストール時にFTP接続情報を入力するように促されて「?」になったので回避メモ。


基本的には「wp-config.php」に以下の行を書きこめばOK。

define('FS_METHOD', 'direct');


更新用(?)のディレクトリが必要になるので「wp-content/upgrade」を作成、パーミッションを書き込み可に変更。
同様に「wp-content/themes」と「wp-content/plugins」にも書き込み許可を与える。

$ mkdir wp-content/upgrade
$ chmod 0707 wp-content/upgrade
$ chmod 0707 wp-content/themes
$ chmod 0707 wp-content/plugins

これでたぶんOKです。